取消
普通评论
普通评论

谷歌敦促国内第三方应用商城将目标API级别提至26(Android 8)

cnbeta(杭州)2019-02-22 17:05
谷歌第三方应用API
信息安全 收藏

  Google一直在提高对Android应用的安全要求。今年早些时候公司宣布了过渡至64位应用的最后期限,并表示在2018年Play应用商城拒绝的APP数量比2017年多了55%。而现在处于安全和隐私方面的考量,Google已经敦促开发人员设置更高的目标 API 级别。

  Google Play 要求新应用(自 2018 年 8 月 1 日起)和应用更新(自 2018 年 11 月 1 日起)将目标 API 级别至少设为 26 (Android 8.0)。不过,Google现在鼓励开发人员设置更高的API级别,从而为用户提供最佳的Android体验。

  自2019年8月开始,提交至Play应用商城的新应用API级别将调整至28(Android 9.0 Pie)。自2019年11月开始,所有的应用更新目标API级别也将调整至28。值得注意的是,目前已经在Play商城上架的应用程序并不受该策略调整,那些在build.gradle文件中使用“minSdkVersion”属性为旧版Android创建应用的开发者也不受到影响。

  Google在博文中还特别提及第三方应用商城,尤其是国内的应用商城(例如OPPO、华为和腾讯)也需要将目标API级别设置为26(Android 8.0)。博文中表示95%非Play商城分发的间谍应用都来自于目标API低于22的应用商城。

  该公司还将以下列方式警告用户不符合要求的应用程序:

  2019年8月开始,如果新应用未达到Level 26或者更高级别,在安装期间将会受到警告

  2019年11月开始:现有APP的更新版本如果未达到Level 26或者更高级别,在安装期间将会受到警告

  2020年起:目标API级别将要求每年推进。

  每次 Android 版本更迭都会对API级别进行一些变更,从而大幅改进安全性和性能,并提升 Android 的整体用户体验。 部分变更仅适用于那些通过其 targetSdkVersion 清单属性(也称为目标 API 级别)明确声明支持的应用。 当您将应用配置为支持最新的 API 级别时,就可确保用户享受这些改进带来的好处,同时还能继续让您的应用在较早版本的 Android 上运行。支持最新的 API 级别还有助于让您的应用利用平台的最新功能,为用户提供愉悦的体验。

责任编辑:王超

点击加载

点击加载

发送
普通评论
发送
普通评论
普通评论

为你推荐

暂无相关推荐